
Project 9
Render a Kitchen

Creating a kitchen in 3D is one of those projects that help a lot in improving our skills. Since a 
kitchen can be created without having to resort to complex modeling skills, it suits the purpose 
of learning to assemble a full scene, adding some textures and learning some lighting tricks. 
Let's create one from scratch and learn some good tools of the trade along the way.

Mission Briefing
We will be building a simple scene of a kitchen, starting with a room that has a big window. 
The window will require some detailing, though not really much.

The main elements of the scene will be some cabinets (both on the floor and the wall), 
along with a kitchen sink and a stove. The cabinets will have a nice wooden texture on their 
drawers and doors, and a simple, circular type of knob. The sink will be quite basic, with a 
fake brushed metal material that we'll create for it. The stove will require more detailed work 
to give it a proper shape and add some minimalistic and cool grills (to be ready to hold the 
pots in the future!). We'll also add a hood, a faucet, and a simple background image.

What Does It Do?
With this project we will learn a few methods and tricks to solve different kinds of problems, 
from very basic methods for creating "boxy" shapes, through some tools that can aid a lot 
when trying to create models with exact measurements (though we will not be using exact 
measurements all the time), and a simple but very good lighting setup requiring just two 
lights and the usage of Ambient Occlusion.

We'll also have the opportunity to work with the Spin tool (to create circular extrusions), 
using some modifiers to speed up the work and ease scene management later, as well as 
general organization and data-sharing options that Blender offers us.
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Why Is It Awesome?
The best thing about this project is that it isn't complex at all, but the final result will have 
a professional and realistic look. We won't even need to apply post-processing to the final 
render (though it could improve the final result, of course) since the render that comes 
straight out of the scene setup is good enough.

Another cool thing that this project will allow us to learn is a simple method to fake a 
brushed metal look, useful in cases where the camera is far enough from the object with the 
material.

The lighting setup will show us how good a render can be without resorting to complex 
lighting setups; in this case we are going to create a setup with only two lights and use 
Ambient Occlusion. The real key to it all is the Ambient Occlusion, but the other element 
allowing us to do it is the area lamp that we're going to use.

All in all, this project is a good way to learn a bit about architectural rendering.

Your Hotshot Objectives
We'll be working in five different parts on the project; each part will include the modeling 
and shading of the objects that we create in it:

ff Room

ff Cabinets

ff Sink and faucet

ff Stove and hood

ff Lighting and background

Mission Checklist
As usual, we're going to need a few textures to apply on some objects of the scene; let's go 
to www.cgtextures.com, and download these textures (remember to put them in a tex 
folder inside the project's folder):

ff Wood → Fine Wood:

�� WoodFine0047 (reddish one, stripes running horizontally); download the 
medium version of the Image 1 of the texture set. An easy way to find 
the right texture is to look at the URL when hovering the pointer on the 
thumbnail; in the URL there must be a part saying id=42044.

ff Skies Partial:

�� Skies0239; this image has a thin part of green land in the bottom. Make 
sure to download the large version of it. The URL must have id=14023.
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ff Buildings → Shops:

�� Shops0204; this image shows the front of a shoe store. Download the 
small version of the first image of the set. The URL must have id=26859.

The first image will be needed for the drawers and doors of the cabinets, the second 
one as a background to the window of the kitchen, and the last one will be used as a 
helper fake reflection map.

Room
Let's open Blender, delete the default camera and lamp, and then go to the Scene tab of 
the Properties Editor and set the units mode to Metric (Units panel); this will make Blender 
show us the values of parameters and some measurements using the metric units system, 
which will be quite helpful. Finally, save the file as kitchen.blend in the project's folder.

Engage Thrusters
We'll start by creating the walls of the room.

1.	 Select the default cube and set its name to walls (in the Item panel of the 
Properties sidebar); then switch to Front View (View → Front) and into Edit Mode 
(press the Tab key). Once in Edit Mode, go to the Mesh Display panel of the 
Properties sidebar and enable the Edge Length and Edge Angles options (under the 
Numerics label).

2.	 Now select all the vertices of the cube and scale them up by a factor of 1.25, 
constrained to the Z axis (press the S key, Z key, then type 1.25). Then let's move all 
the vertices so that one of the vertices of the mesh gets properly positioned at the 
origin of the 3D world. To do that, let's move them by one meter on the X axis (press 
the G key, X key, then type 1), then move them by -1 meters on the Y axis (press the 
G key, Y key, then type -1), and finally move them upwards (Z axis) by 1.25 meters 
(hit the G key, Z key, then type 1.25).

To open the mesh and be able to see inside we need to remove one of its edges.
3.	 Let's select the edge running along the Z axis that, if viewed from the top, would be 

located at the bottom right (it would be seen as a point, not as a line); once the edge 
is selected, let's delete it (Mesh → Delete → Edges). Now we have the corner in 
which all our scene will be constructed.

4.	 Now let's add an edge loop by using the Loop Cut and Slide tool (in the Tool Shelf 
sidebar) and clicking on one of the edges parallel to the Y axis, so that the resulting 
loop would look like a "C" if viewed from the Front View. Right after creating the 
new loop, let's select it and move it by -70 cm on the Y axis (press the G key, Y key, 
then type -0.7). That way it will be 1.7 meters from the origin of the 3D world.
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5.	 Another edge loop must be added to the mesh, this time running horizontally (after 
selecting the Loop Cut and Slide tool, click on one of the edges running parallel to 
the Z axis). Once added, let's select it and move it down so that the vertical edges 
below it are one meter long (let's use the labels indicating the lengths that appear 
over them while performing the transformation).

6.	 Let's also switch to Front View (View → Front), select the vertices at the rightmost, 
and move them one meter to the right (press the G key, X key, then type 1).

7.	 To complete the wall we just need to create an opening for the window. To do that, 
let's switch to Right View (View → Right), select the face touching the upper right 
corner of the "box", extrude it, and then scale the extruded the face down by a 
factor of 0.873 (the length indicators in the diagonal edges must show a value of 
14.42 cm approximately). To have evenly distributed angles, let's now scale the face 
by a factor of 1.0172 along the Y axis (press the S key, Y key, then type 1.0172).

8.	 Finally let's switch to Face Select Mode, select the inner face from the extrusion and 
delete it (Mesh → Delete → Faces). Now we have the place to put the window in.

9.	 A small tweak to finish the modeling is to select the entire mesh (Select → Select/
Deselect All, once or twice) and go to Mesh → Normals → Recalculate Inside.

Let's take a look at a screenshot showing our progress so far:

10.	 For the shading part, let's go to the Material tab in the Properties Editor, add a new 
material to the material slot (if there's not one yet), change its name to wall and 
set it as follows:

ff Diffuse panel:

�� Color: 0.9 Red, 0.9 Green, 0.9 Blue

�� Intensity: 0.9
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ff Specular panel:

�� Color: 1.0 Red, 1.0 Green, 1.0 Blue

�� Intensity: 0.24

�� Shader Model: CookTorr

�� Hardness: 12

That way we get a basic look with a low specularity and very bright look. To avoid 
having unnecessary textures, let's go to the Texture tab and make sure this material 
doesn't have any texture associated with it. Now let's work on the window.

11.	 To make constructing the window a little easier, let's just select the edges forming 
the hole of the window in the walls, duplicate them (Mesh → Add Duplicate) and 
then separate them into a new object (Mesh → Vertices → Separate).

12.	 Then switch to Object Mode, select the new object and set its name to window (in 
the Item panel, Properties sidebar). Let's also switch to Edit Mode (Tab key) for this 
object.

13.	 Select all the edges, extrude them (press the E key) and then press the Escape key. 
Move the extruded geometry by 1 cm (0.01 units) along the global X axis. Right after 
that, let's perform a second extrusion, press Escape, and then scale the selection 
by a factor of 0.927. To get a nicely proportional corner, let's scale the selection 
only along the Y axis (press the S key, then Y) and move the mouse pointer until the 
labels showing the angles' values get as close to 135º as possible (hold the Shift key 
while moving the pointer to have finer control).

14.	 Continue by extruding again (press the E key, followed by Escape) and then scale 
down the extrusion by a factor of 0.9893. Then let's perform a scale constrained 
to the global Y axis (press the S key, then Y) until the angle values become close to 
135º. Note the thin ring we just created, since we will select it later to perform an 
inset.

15.	 Once again, let's extrude the selected edges, press the Escape key to stop the grab 
operation and scale the selection by a factor of 0.9215. This time we must also 
correct the angles by scaling the selection constrained on the Y axis (press the S key, 
then Y) until the labels showing the angles' values indicate a value as close to 135º 
as possible.

16.	 To complete the frame of the window, let's just extrude the inner ring and move the 
extrusion -6 cm (0.06 units) along the global X axis. Let's also remember to select 
the faces forming the thin ring created in one of the previous extrusions, extrude it 
and move it -1 cm (0.01 units) along the global X axis.
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To make sure that we are on the right track, let's take a look at a screenshot of how 
the corner of the window frame should look by now:

17.	 The final touch for the window is just adding some simple "muntins" to it. Let's 
select the inner ring of edges and position the 3D Cursor at the center of the 
selection by going to Mesh → Snap → Cursor to Selected. Then we need to add a 
cylinder (Add → Mesh → Cylinder) and set its parameters (in the Tool Shelf sidebar, 
lower panel) as follows:

ff Vertices: 8

ff Radius: 0.01

ff Depth: 1.12

ff Cap Ends: disabled

18.	 Now let's switch to Top View (View → Top) and move the cylinder by 2.7 cm (0.027 
units) along the global X axis. Then let's duplicate the cylinder (Shift + D) and move 
it by 32 cm (0.32 units) along the global Y axis; to create the third muntin let's just 
duplicate this second one and move the duplicate -64cm (0.64 units) along the Y axis.

19.	 The only missing part is creating a horizontal frame. For that, let's switch to Right View 
(View → Right), select only the muntin in the center, duplicate it (Shift + D), rotate 
the duplicate by 90 degrees, and scale it constrained to the Y axis until it touches both 
sides of the inner part of the frame. Let's also select the entire mesh (Select → Select/
Deselect All, once or twice) and go to Mesh → Normals → Recalculate Outside; that 
way we are sure the normals are pointing in the correct direction.

20.	 It's quite likely that the muntins will be using flat shading, so let's select them and go 
to Mesh → Faces → Shade Smooth.



Project 9

7

21.	 Now let's create the material for the window; switch to Object Mode, then go to 
the Material tab of the Properties Editor, add a new material, and set its name to 
whiteWood; then set it as follows:

ff Diffuse panel:

�� Color: 1.0 Red, 0.98 Green, 0.94 Blue

�� Intensity: 0.9

ff Specular Intensity: 0.0 (Specular panel)

That will give us a simple flat, subtly warm, soft finish for the whiteWood material. It's a 
good idea to save our file now.

Objective Complete - Mini Debriefing
In this part we just worked out the room that contains our scene; the room itself is very 
simple, composed of just a corner with a window. To give it a little bit of detail, we just 
performed some work on the frame of the window.

The materials were very straightforward, using just basic diffuse and specular settings to 
accomplish the needed finishing.

Cabinets
With the room ready, we can create the cabinets, both on the floor and high on the wall. The 
cabinets will be composed of a very basic "cubic" shape, a drawer, a door and a knob.

Engage Thrusters
1.	 Let's start by checking that we are in Object Mode (switch to it if not) and the 3D 

Cursor is positioned at the origin of the 3D World (press Shift + C to move it there).

2.	 Now let's add a new cube (Add → Mesh → Cube), set its name to cab-floor (from 
the Item panel, Properties sidebar) and switch to Edit Mode.

3.	 Select all the vertices (press the A key, once or twice) and scale it down by a factor 
of 0.5; this will give us a cube 1 meter (1 unit) long in each dimension. Now let's 
move the selection by 50 cm X, -50 cm Y, 50 cm Z; a nice and easy way to do that 
is to start the grab tool (G key), then type 0.5, followed by Tab (notice the vertical 
bar indicating which axis are you typing the value in, in the status bar below the 3D 
View), then type -0.5, followed by Tab, then type 0.5 and then press Enter. After 
this, we must have the cab-floor object's corner and the room's corner at the 
exact same place (the origin of the 3D world).
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4.	 Now let's switch to Face Select Mode (Ctrl + Tab, then type 3), switch to Front View 
(View → Front), select the rightmost face of the mesh, and move it -50 cm along the 
X axis (press the G key, X key, then type -0.5).

5.	 Now add an edge loop by using the Loop Cut and Slide tool (Tool Shelf) and 
performing the cut parallel to the X axis (from Right View). Make sure to perform the 
cut at the very center of the edges, so that the split new edges are each 50 cm long.

6.	 Right after that, let's select the leftmost face and move it -50 cm along the Y axis (G 
key, Y key, then type -0.5).

7.	 Let's now make sure that we have the Limit Selection to Visible option enabled 
(first button on the right-hand side of the vertex/edge/face selection mode buttons, 
header of the 3D View) and that we are viewing the viewport shading in solid mode 
(Z key, once or twice); now select the face to the right-hand side (not the one that 
appears as an edge from our view angle), then switch to Front View (View → Front), 
extrude the face, press Escape, then move the extrusion by 1.5 meters (1.5 units) 
along the X axis (G key, X key, then type 1.5).

8.	 Then let's add two edge loops across the extrusion by using the Loop Cut and Slide 
tool (Ctrl + R) and scrolling the mouse wheel to increase the number of cuts. Finally, 
let's rotate the view freely (drag the middle mouse button), select the five faces that 
are located highest in the Z axis, and move them down 20 cm (G key, Z key, then 
type -0.2). Let's take a look at the "L" shape that we just created:

9.	 Before continuing, let's check that the height of the cabinets is 80 cm, their 
"thickness" is 50 cm, the left arm is 1 meter long, and the right arm is 1.5 meters 
long. Let's also add a new edge loop to the left arm to split it into two parts, each 50 
cm long. Pay attention to the faces that will have drawers or doors (the vertical ones, 
in the inner part of the L shape), since we will be working on them next.
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10.	 Let's now switch to Object Mode, then go to the Material tab of the Properties 
Editor, click on the red sphere icon (just below the empty materials list), and 
select the whiteWood material. That way we share the same material between 
the window frame and the cabinet.

11.	 To create the drawers, let's switch to Edit Mode and make sure we are in Front View 
(View → Front) and the Viewport Shading is set to solid. Then select the rightmost 
face over which there will be a drawer. Let's duplicate it and separate it into a new 
object (Mesh → Vertices → Separate).

12.	 Now switch back to Object Mode, select the new object, set its name to  
cab-drawer (Item panel, Properties sidebar), and switch into Edit Mode again.

13.	 With the face selected, scale it down by a factor of 0.94 (press the S key, then type 
0.94). Then perform a second scale operation, restricted to the global Z axis, with a 
factor of 1.027. Next we need to extrude the face, press Escape, and then move the 
extrusion -1 cm along the Y axis (G key, Y key, then type -0.01). That way we give 
some thickness to the drawer.

14.	 Let's continue by extruding the front face of the drawer, pressing Escape, then 
scaling it by a factor of 0.944. Apply a second scale, restricted to the Z axis and use 
the angle values to determine how much to scale the face (remember to get the 
angles reading as close as possible to 135º).

15.	 In order to create the ring needed for the inset, we need to perform a new extrusion 
(using the selection that the previous extrusion left us with), scale it down by a 
factor of 0.975 and then scale it up (only along the Z axis) so that the values shown 
in the angle labels are as close to 135º as possible. Then let's select the thin ring 
that we just created with this extrusion, extrude it, press Escape, and then move the 
extrusion 2 mm (0.002 units) along the Y axis (G key, Y key, then type 0.002).

16.	 To add the knob, let's switch to Edge Select Mode and Front View (View → Front), 
select one of the horizontal edges in the upper side of the drawer, and then put the 
3D Cursor on it (Mesh → Snap → Cursor to Selected). Then add a new UV Sphere 
(Add → Mesh → UV Sphere) and set the parameters for it as follows (Tool Shelf):

ff Segments: 16

ff Rings: 16

ff Size: 0.021

ff Align to View: enabled

Let's also click on the Smooth button to get the knob shaded correctly.
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17.	 Now let's switch to Top View (View → Top), select the vertex at the north pole 
(upper vertex in the screen), enable the Proportional Editing mode, set it to smooth, 
and then move the vertex in the negative direction of the Y axis, until the shape 
of the knob is almost flat on the upper part (use the scroll wheel to control the 
influence radius of the Proportional Editing mode). At this point, remember to 
disable the Proportional Editing mode. Then let's go to Select → More, extrude, 
press Escape, and then move the extrusion by 1.5 cm along the Y axis (G key, Y key, 
then type 0.015).

18.	 To move the knob into the correct location, let's select the whole knob (Select 
→ Linked, from the pre-existent selection) and move it so that it gets correctly 
separated from the drawer surface. Then switch to Right View and move it down so 
that it gets located inside the "ring" of the inset of the drawer; not at the center of 
the drawer, but in the upper part.

19.	 Since this first drawer will have the knob at the center, it's better for it to have 
lesser height; let's switch to Front View (View → Front), select the lower part of the 
drawer and move it up by 52.2 cm (0.522 units along the Z axis); that way we get a 
nice drawer.

Before starting to duplicate this drawer to create the bigger ones, let's make sure 
to assign the proper materials to it; that way we avoid having to go into each object 
later to link it with the material.

20.	 Let's switch to Object Mode, then go to the Material tab of the Properties Editor 
and add two slots to the materials list. Then add a material to each slot by clicking 
on the slot itself and then clicking on the New button, right below the materials list. 
Make sure that each slot has a separated material by checking that the names of the 
materials are different. The first material must be named cabinetDrawer and the 
second one must be named cabinetKnob.

21.	 Let's start with the settings for the cabinetDrawer material:

ff Diffuse Color: 0.0 Red, 0.0 Green, 0.0 Blue (Diffuse panel)

ff Specular panel:

�� Color: 1.0 Red, 0.825 Green, 0.48 Blue

�� Specular Shader Model: CookTorr

�� Intensity: 0.31

�� Hardness: 20

22.	 Now go to the Texture tab of the Properties Editor, add a new texture, set its name 
to finewood, its type to Image or Movie, and then set it as follows:

ff Mapping panel (the axis mapping options are the ones just below the Projection 
drop-down):
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�� X Mapping: Z

�� Y Mapping: X

�� Z Mapping: Y

ff Image panel: load the image WoodFine0047_3_M.jpg from the tex folder.

ff Influence panel:

�� Diffuse Color: Enabled, 1.0

�� Normal: Enabled, -0.3 (under the Geometry label)

�� Blend Mode: Add

Our material uses just the standard black color for the diffuse channel (to add the 
color from the texture) and a basic specularity with some tint. The trick with the 
texture is to get it running vertically on the drawer (the original texture is horizontal) 
by adjusting  the axis mapping parameters. We also enabled the normal option to 
give some subtle roughness to the surface.

23.	 Let's go back to the Material tab, select the cabinetKnob material and set it as 
follows:

ff Diffuse Color: 0.8 Red, 0.79 Green, 0.68 Blue (Diffuse panel)

ff Specular panel:

�� Color: 1.0 Red, 1.0 Green, 1.0 Blue

�� Specular Shader Model: CookTorr

�� Intensity: 1.0

�� Hardness: 26

24.	 Then let's go to the Texture tab, add a new texture, change its name to spatter, 
its type to Clouds and set it as follows:

ff Clouds panel:

�� Basis: Voronoi F2-F1

ff Ramp: Enabled (Colors panel)

ff Mapping panel:

�� X Size: 5.0

�� Y Size: 5.0

�� Z Size: 5.0

ff Influence panel:

�� Diffuse Color: Enabled, 1.0

�� Blend: Mix
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25.	 The settings for the ramp are as follows:

ff Interpolation: Cardinal

ff Color stop 1:

�� Color: 0.0 Red, 0.0 Green, 0.0 Blue

�� Alpha: 0.0

�� Position: 0.13

ff Color stop 2:

�� Color: 0.30 Red, 0.38 Green, 0.30 Blue

�� Alpha: 0.21

�� Position: 0.34

This material is just a basic plastic material with simple noise to add a bit of texture 
to the overall look.
Now that we have the materials defined, it's time to assign each material to the 
faces that must have it applied.

26.	 Let's switch to Edit Mode, select only the vertices of the knob (select one vertex 
and then press Ctrl + L), go to the Material tab of the Properties Editor, select the 
cabinetKnob material, and click on the Assign button (just below the materials 
list); to assign the cabinetDrawer material, let's select only the drawer, select the 
cabinetDrawer material from the list, and then click on Assign.

27.	 Switch back to Object Mode, duplicate the cab-drawer object (Object → 
Duplicate) and move it -49.5 cm along the X axis (G key, X key, then type -0.495). 
This new object must be named cab-drawer-big (Item panel, Properties sidebar).

28.	 Since this will be a cabinet door, the current location for the knob isn't really 
appropriate; let's switch to Edit Mode, select only the vertices forming the knob, 
and move them -17 cm (0.17 units) along the X axis (G key, X key, then type -0.17). 
To give this door the correct height, let's select just the lower part of the door 
(including the lower part of the inset) and move it -52.5 cm along the Z axis (G key, Z 
key, then type -0.525). Switch back to Object Mode.

The two types of objects that we need are done; what we must do now is replicate 
them on the correct locations.
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29.	 Let's start by selecting the cab-drawer object, then go to the Modifiers tab of the 
Properties Editor and add an Array Modifier. Make sure to use the Fixed Count 
option for the Fit Type, increase the Count to 3, enable Relative Offset and set the 
Z value for the Relative Offset to -1.05 (the X and Y values must be zero). This first 
modifier will get the drawers replicating vertically. Now let's add another Array 
Modifier, use Fixed Count for the Fit Type, leave the Count at 2, enable Relative 
Offset and set the X value for it to -2.1 (Y and Z must be zero). With these two 
modifiers we got the drawer replicated nicely and, along with cab-drawer-big, 
filling the entire right arm of the basic shape that we modeled initially.

30.	 For the left arm of the main "L" shape we just need to duplicate (Object → 
Duplicate) the cab-drawer-big object (in Object Mode), rotate it 90 degrees on 
the Z axis (R key, Z key, then type 90), then go to the Modifiers tab and add an Array 
Modifier set to use Fixed Count, 2 elements (Count parameter), Relative Offset 
enabled and an offset value of -1.05 in the X component (Y and Z must be zero). 
Then let's switch to Top View (View → Top) and move the repeating cab-drawer-
big (it must have a name ending with .001) to be located just on the left arm of the 
main "L" shape for the cabinets that are on the floor.

Let's take a look at the progress so far:

31.	 Next we must create the cover for these cabinets. Let's select the cab-floor 
object, select the faces forming the upper (according to the Z axis) "L", duplicate 
them (Mesh → Add Duplicate) and then separate them into a new object (Mesh → 
Vertices → Separate).

32.	 Now switch to Object Mode, select the new object, set its name to cab-cover 
(Item panel, Properties sidebar) and switch to Edit Mode. Select all the faces (if they 
are not selected already) and extrude them, then press Escape, and then move the 
extrusion 2 cm along the Z axis (G key, Z key, then type 0.02).
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33.	 With the thickness for the cover already created, let's now work on giving it some 
extra tweaks. Switch to Top View, set the Viewport Shading to Wireframe (press 
the Z key, once or twice) and use the Circle Select tool (Select → Circle Select) to 
select the vertices that would be visible if we looked at the cab-cover from the 
front (having the Viewport Shading set to solid); let's also select the vertices in the 
inner corner of the "L". Press the Escape key to close the Circle Select tool and then 
move the selection -1 cm along the Y axis (G key, Y key, then type -0.01). Deselect 
everything (press the A key) and then select the vertices that would be visible if we 
looked at the cab-cover from the right-hand side (with Viewport Shading set to 
solid). Then let's move the selection 1 cm along the X axis (G key, X key, then type 
0.01).

34.	 To give the cab-cover a good shape in the border where it touches the wall, let's 
add two edge loops; start by adding an edge loop along the left arm of the "L" shape 
and move it in the negative direction of the X axis until the split edges are 2 cm and 
49 cm long. Let's perform the same operation, adding a new edge loop (using the 
Loop Cut and Slide tool) along the right arm of the "L" shape of the cab-cover; 
then let's move it until the split edges are 49 cm and 2 cm long.

After adding these new edge loops, there must be a very thin set of faces on the 
border of the cab-cover, having an "L" shape; this new thin "L" shape must touch 
the wall.

35.	 Let's now select the outer vertices of this new, thin, "L" shape and move them 1 cm 
(0.01 units) along the Z axis (G key, Z key, then type 0.01). A screenshot can help us 
make sure we get the right shape:
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36.	 Let's now add the material to the cab-cover object; but this time we're just going to 
copy a pre-existing material (creating a separate copy, not reusing it). Switch to Object 
Mode, go to the Material tab in the Properties Editor, add a new material and change 
its name to cab-cover. Now select the cab-drawer object, go to the Material tab 
of the Properties Editor, select the cabinetKnob material from the list, click on the 
arrow pointing downwards (to the right-hand side of the Materials list), and select the 
Copy Material entry from the menu. Now let's select the cab-cover object again, go 
to the Material tab in the Properties Editor, click on the arrow pointing downwards 
to the right-hand side of the Materials list, and select the entry Paste Material from 
the menu. That way we copied the settings from the cabinetKnob material into the 
cab-cover material. This leaves us with two materials that have the same settings 
but are independent (thus not affecting each other when modifying the material 
settings). There's a catch, though; since the texture is shared between the two 
materials, any modification in the texture will affect both materials.

For the remaining cabinets, let's first take a look at a screenshot to guide us:

37.	 The steps to create these cabinets are quite straightforward. Starting with the existing 
ones, let's duplicate the last segment of the right arm of the cab-floor object (the 
one over which we modeled the first drawer) and separate it into a new object.

38.	 Name the new object as cab-wallA, move it up and to the left-hand side to 
position it near the window (but not too close). Let's also switch to Edit Mode for 
the cab-wallA object, fill any hole that the "box" may have (almost surely to the 
left-hand side) by selecting the vertices and pressing F, then let's move the front 
face of the box so that the thickness of the cabinet is just 40 cm.
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39.	 To put the door in front of the cab-wallA object, let's just select one of the 
cab-door objects, duplicate it (Shift + D) and move it to get it correctly positioned. 
Let's also rotate it 180º (from Front View), so that the knob gets positioned below.

40.	 For the second and third cabinets that must go on the wall, it's just a matter of 
selecting both the box and the drawer of the first, duplicating them and moving 
each duplicate to the correct location. The previous screenshot is very helpful to 
know where to put the duplicates.

At this point we are done with the cabinets; let's now work on creating the sink and the 
faucet. Don't forget to save the file.

Objective Complete - Mini Debriefing
In this part we worked with fairly basic shapes (mostly square boxes) to create the cabinets 
for our scene. We started with a general ("L") shape for the cabinets on the floor, then 
created a drawer and a door, each with a knob. As a finishing touch we added a cover with a 
nice "beveled" shape on its border.

This time we used some small but useful tricks such as duplicating parts of an object to use 
as the starting point for another one, and creating slightly modified versions of the same 
basic shape (what we did with the drawers and doors).

Sink and Faucet
The sink is a key element in any kitchen scene. In this project we are going to create a basic 
sink and add a simple material to give it a simulated brushed-metal look.

Prepare for Lift Off
Both the sink and the stove (the next part of the project) require that we perform some 
small adjustments to the cab-cover and the cab-floor objects. What we need to do is 
to open the holes in those objects where the sink and the stove will be located. In the next 
screenshot we can see the highlighted faces of the cab-cover that must be selected and 
deleted (Mesh → Delete → Faces):
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Remember that we must delete other faces just below the two shown in the screenshot (in 
the cab-floor object). Let's also keep in mind that the hole on the short arm of the "L" is 
the location for the sink, and the other one is the location for the stove.

Now let's select the border of the hole for the sink, extrude it, press Escape, and then scale it 
down by a factor of 0.87 (press the S key, then type 0.87). Then let's scale only along the X axis 
until the labels showing the angles' values read 135º (or as close as possible). Right after that, 
let's switch to Edge Selection Mode, select the edge close to the border of the cab-cover (the 
border of the cab-cover is the raised part, touching the wall), and move it 5 cm along the X 
axis (press the G key, X key, then type 0.05). Now we have the place for the sink ready.

Engage Thrusters
1.	 Let's select the border of the hole for the sink, duplicate it (Mesh → Add Duplicate), 

press Escape and then separate the copy into a new object (Mesh → Vertices → 
Separate → Selection).

2.	 Now switch to Object Mode, select the new object, set its name to sink (from the 
Item panel, Properties sidebar), and enter Edit Mode.

Since explaining the process of modeling the sink and the faucet in words would be 
quite complex, let's use a couple of screenshots to guide our way. First, let's see the 
finished result:
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In this screenshot we can see both the sink and the faucet. Take some time to look 
at the shape of the models closely, to get acquainted with what we are going to do. 
Now, let's use a screenshot showing the steps to model the sink:

The first step is the one showing a simple ring, the next ones are alongside it and 
then below. The screenshot was taken from a non-standard view so that the shapes 
of the models can be seen more easily. Now we can follow the steps easily to create.

3.	 Let's start by going to the Modifiers tab in the Properties Editor and adding a 
Subdivision Surfaces modifier to the sink. Make sure to set the View parameter to 
2 and enable Apply modifier to editing cage during Editmode (triangle icon, to the 
right-hand side of the name of the modifier).

4.	 Select the four vertices of our mesh, extrude them, then press Escape, and now 
scale the extrusion down by a factor of 0.75 (S key, then type 0.75). That will create 
a basic ring. Now let's move it 3 cm along the Z axis (press the G key, Z key, then type 
0.03). At this point we should have the same mesh as shown in the first step of the 
screenshot.

5.	 After moving it up, let's extrude it, press Escape, and then move the extrusion -23 
cm along the Z axis (press the G key, Z key, then type -0.23). To finish the initial 
shape let's go to Mesh → Faces → Make Edge/Face. That will leave us with the 
second step done.

6.	 For the third step, we only need to switch to Top View (View → Top) and add 
five edge loops (Loop Cut and Slide tool): two running horizontally, two running 
vertically, and one surrounding the face of the bottom. To get the correct shape, the 
edge loops must be put very close to the corners. This gives us the mesh shown as 
the third step in the screenshot.
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7.	 The next thing to do is select the three edges of the sink that run parallel to the 
border of the cab-cover and are closer to it, then extrude them, press Escape, and 
finally move the extrusion -5 cm (0.05 units) along the X axis (G key, X key, then type 
-0.05). Since this "flat" protrusion will overlap with the cab-cover, let's move it 1 
mm along the Z axis (G key, Z key, then type 0.001). With these operations we get 
to step four, as seen in the previous screenshot.

8.	 For the final (fifth) step of the process, we just tweak some vertices in the corners of 
the sink to soften them. Look carefully at the image for the last step and compare it 
to the previous one to see the subtle difference. Finally, let's make sure to select the 
entire mesh and set the shading to Smooth (from the Tool Shelf).

If the mesh starts to show weird black spots after setting the shading 
to smooth, we just need to select all the vertices and then go to Mesh 
→ Normals → Recalculate Outside. To fine-check that the normals get 
oriented correctly, we just need to enable the Face Normals option in 
the Mesh Display panel of the Properties sidebar.

For the faucet, we're going to need more screenshots. Let's start with the first part:

9.	 Let's make sure we are in Edit Mode for the sink object, select the two corners of 
the last protrusion we created, and then go to Mesh → Snap → Cursor to Selected. 
Now let's switch to Object Mode and start working on the new object for the faucet.

10.	 Go to Add → Mesh → Circle to add a new object to the scene. Then let's set its 
parameters (Tool Shelf) to 8 vertices, radius of 0.01, and disable Fill. For the name 
of the object, let's change it to faucet (Item panel, Properties sidebar). With the 
faucet object selected, let's switch to Edit Mode.
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11.	 Start by switching to Front View (View → Front), select all the vertices (press the A 
key, once or twice), extrude, press Escape, and then move the extrusion 12 cm along 
the Z axis (press the G key, Z key, then type 0.12).

12.	 With the extruded ring still selected, let's go to Mesh → Snap → Cursor to Selected 
to put the 3D Cursor at the center of the vertices forming the selection.

13.	 Now go to the Tool Shelf and click on the Spin button to run the Spin tool. It 
will create a small set of extrusions around the 3D Cursor. Now let's locate the 
parameters for the Spin tool (lower part of the Tool Shelf), set Steps to 9, Degrees 
to 180 and then add 5 cm (0.05 units) to the X value for the Center. That gives us a 
circular shape, as seen in the second step of the screenshot.

14.	 To complete this part of the mesh, we just need to add some detail to the tip of the 
circular mesh created by the Spin tool by extruding twice and tweaking by scaling 
the rings from the extrusions. Let's also add two new edge loops in the base of the 
mesh and tweak them (by scaling) until we get the shape shown in the third step of 
the screenshot.

15.	 To finish this part, we need to switch to Edge Select Mode, select the second and 
third rings from the base and the second and third from the tip (four in total), and 
then go to Mesh → Edges → Mark Sharp. Now go to the Modifiers tab, add an Edge 
Split modifier and disable the Edge Angle option (leave only the Sharp Edges option 
enabled). Right after that modifier, let's add a second one, this time a Subdivision 
Surface modifier and set the subdivisions level to 2 for View.

For the second part of the faucet, let's take a look at the screenshot showing us the process:

16.	 Start by switching to Top View (View → Top), then select the ring at the base of the 
first part of the mesh, duplicate it (Mesh → Add Duplicate), press Escape, and move 
it 12 cm along the Y axis (press the G key, Y key, then type 0.12).
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17.	 Now switch to Right View (View → Right) to start working on the model. With the 
duplicated ring selected, let's extrude it, press Escape, and move the extrusion up 5 
cm (0.05 units). Then let's scale the top part by a factor of 0.3 (press the S key, then 
type 0.3). This gives us the mesh shown as the first step in the previous screenshot.

18.	 For the second step, we just need to perform one more extrusion, move it up 
slightly and scale it down by a factor of 0.5. Right after that, let's go to Mesh → 
Faces → Fill to automatically fill the ring with faces, then let's go to Mesh → Faces 
→ Tris to Quads to do a basic cleanup of the automatically generated faces. This last 
step is needed to avoid having triangles, since they do not play very well with the 
Subdivision Surface modifier. At this point we have completed the second step from 
the screenshot.

19.	 To improve the shape, let's add two edge loops running horizontally (using the Loop 
Cut and Slide tool) and then scale them up slightly. With this we get the shape 
shown as step three.

20.	 The final operations are just a few extrusions and some careful hand-tweaking. Let's 
select two neighboring faces from in between the latest edge loops that we added, 
and perform three successive extrusions to form the protruding shape shown as 
step four in the screenshot. With the extrusions done, it's just a matter of playing 
around and tweaking carefully to get the final shape. The last touch to complete it 
is to add a new edge loop surrounding the very beginning of the base of the first 
extrusion; that way we give some sharpness to that part of the mesh.

At this point we just need to take a look at the first screenshot for this part of the 
project to make sure that we have both the sink and the faucet positioned as they 
should be. Now let's work on the material for these objects.

21.	 Let's switch to Object Mode and select the sink object. Now go to the Material tab 
in the Properties Editor, add a new material, change its name to brushedMetal, 
and set it up as follows:

ff Mirror panel: Enabled

�� Reflectivity: 0.6

�� Gloss Amount: 0.8

These basic settings will just give the material strong reflectivity and blur it quite a lot.

22.	 Now let's go to the Texture tab of the Properties Editor, add a new texture, change 
its name to fake-refl, its type to Image or Movie, and then set it up as follows:

ff Mapping panel:

�� Coordinates: Reflection

�� Projection: Sphere

�� Size: 0.1 X, 0.1 Y, 0.1 Z
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ff Image panel: Load the image Shops0204_1_S.jpg

ff Influence panel:

�� Diffuse Color: Enabled, 1.0

�� Blend Type: Mix

This texture adds a bit of color variation to the blurry reflection of the basic material; 
that way we get a quite believable brushed metal look (when seen from a distance, 
as in this scene).

23.	 The only missing step to perform is to select the faucet object (in Object Mode), go 
to the Material tab of the Properties Editor and then select the brushedMetal 
material from the drop-down list of the available materials. Remember to save the 
file now.

Objective Complete - Mini Debriefing
In this part we concentrated on creating the sink and faucet for our kitchen. The modeling 
required applying some common techniques such as adding extra edge loops close to the 
corners to get them looking sharp and using the Mark Sharp option to apply the Edge Split 
modifier in a very controlled way.

The shading of the two objects was quite easy, requiring only that we set up a simple blurry 
reflection and add an image texture to give some richness to the colors on the surface.

Stove and Hood
Now let's work on the final part that requires modeling, the stove and the hood. For the 
stove we are going to create a very nice shape, with a very basic set of grids to support 
the pots (not modeled in this project). The hood will be quite easy to model, and the 
brushedMetal material that we created previously will give it a very nice finish.

Engage Thrusters
1.	 Let's select the cab-cover object (in Object Mode) and switch to Edit Mode. 

Then select the ring of faces that form the hole where the stove will be positioned, 
duplicate it (Mesh → Add Duplicate) and separate it into a new object (Mesh → 
Vertices → Separate → Selection).

2.	 Now switch back to Object Mode, select the new object, change its name to stove 
(Item panel, Properties sidebar) and switch to Edit Mode and Top View (View → 
Top), to start working on the actual model.
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For this model, let's also use a screenshot showing the steps:

3.	 Make sure to have the four vertices selected, extrude them, press Escape and then 
scale the extrusion by a factor of 0.84. Then let's scale again, this time only along the 
X axis, to adjust the angles' values to 135º. Then let's move the selection 1 cm along 
the Z axis (press the G key, Z key, then type 0.01) and go to Mesh → Faces → Make 
Edge/Face. To get the mesh shown as in step one in the screenshot we just need to 
add a Subdivision Surface modifier. To do that, let's go to the Modifiers tab in the 
Properties Editor, add a Subdivision Surface modifier, and set the view subdivisions 
value to 2.

4.	 To add the two edge loops running vertically, let's use the Loop Cut and Slide tool 
and increase the number of cuts by scrolling the mouse wheel. Once the edge loops 
are added, we should have the shape shown in step two.

5.	 For the third step we only need to select the two edge loops that we added in step 
two, and scale them along the X axis by a factor of 0.25 (press the S key, X key, then 
type 0.25).

6.	 The next thing to do is add four edge loops (two horizontal, two vertical), one by 
one, and slide them to get the corners of the mesh very sharp. After doing this we 
should have the mesh shown in step four.

7.	 The two final steps are done by selecting the two biggest faces of the mesh, 
extruding them, pressing Escape, then moving them -3 cm along the Z axis 
(press the G key, Z key, then type -0.03). Now add two more edge loops running 
horizontally (across the sunken faces) to sharpen the corners. Another couple of 
edge loops must be added running vertically, but this time across the "bar" that 
separates the two sunken parts. With this we have the structure of the stove done, 
as shown in step six of the screenshot.
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8.	 To complete the stove we must create a set of grills that serve to hold the pots. Let's 
start by selecting one of the edges in the upper part of the stove and then go to 
Mesh → Snap → Cursor to Selected. Now that we have the 3D Cursor positioned 
properly, let's switch to Front View (View → Front), add a new cylinder, and set 
its parameters as follows: 8 vertices, 0.001 radius, 0.1 depth, cap ends disabled. 
Now rotate the cylinder 90 degrees (press the R key, then type 90) to get it 
oriented horizontally. To guide you through the process, take a look at the following 
screenshot:

In the screenshot we can see the simple cylinder at the top; then we add a circular 
segment to each side and then we add an extrusion down to give it some height. 
Let's see how to build it.

9.	 Switch to wireframe mode for the Viewport Shading, select only the eight vertices 
on the right-hand side of the cylinder and go to Mesh → Snap → Cursor to Selected; 
this will position the 3D Cursor in the middle of the selected vertices.

10.	 Now let's go to the Tool Shelf and click on the Spin button to use the Spin tool; to 
give the spin the right shape, let's locate the tool parameters in the Tool Shelf and 
subtract 5 mm (0.005 units) from the Z value of the Center parameter. That will 
move the circular extrusion downwards to form the right shape.

11.	 Now go to the left-hand side of the cylinder, select only the 8 vertices there, then go 
to Mesh → Snap → Cursor to Selected and then invoke the Spin tool (Spin button 
in the Tool Shelf). This time we must subtract 5 mm (0.005 units) from the Z value of 
the Center parameter and invert the sign of the Y value of the Axis parameter.
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12.	 Right now we should have the shape shown in the third image of the screenshot. 
Then it's just a matter of selecting the two rings (16 vertices in total) at the tips of 
the spin extrusions, extruding them, pressing Escape, and moving the extrusions 
down by 3 cm (press the G key, Z key, then type -0.03). To finish the basic piece for 
the grill, let's just select all its vertices (put the mouse pointer over it and press the L 
key) and set its shading to smooth (Smooth button, in the Tool Shelf).

13.	 To replicate the basic piece and form a complete grid, let's switch to Top View (View 
→ Top), select the entire piece, duplicate it (Mesh → Add Duplicate), press Escape, 
and then move it -3 cm along the Y axis (press the G key, Y key, then type -0.03). 
Repeat these steps to create a third piece; then select two entire pieces, duplicate 
them (Mesh → Add Duplicate), rotate them 90 degrees (press the R key, then type 
90) and move them to the center of the initial three pieces. At this point we should 
have an entire grill done.

14.	 We only need to select all the pieces forming the grill, switch to Top View (View → 
Top), move it to the correct place inside the stove, then create three duplicates and 
move them to the other positions inside the stove (do it one by one). At the end we 
have a finished stove, as shown in the following screenshot:

15.	 Now let's add the material to the stove. Switch to Object Mode, go to the Material 
tab of the Properties Editor, add a new material (look for the New button, just 
below the empty materials list), change its name to stove, and set it as follows:

ff Diffuse Color: 0.0 Red, 0.006 Green, 0.004 Blue (Diffuse panel)

ff Mirror panel: Enabled

�� Reflectivity: 0.15

�� Fresnel: 5.0

�� Gloss Amount: 0.4
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That's it; it will give us a fairly basic but nice material for the stove. Even though the 
material settings are very simple, the good thing is that using blurred reflections 
(gloss amount less than 1.0) gives very nice results without too much effort.

16.	 Now we must create the hood. Let's go into Edit Mode for the stove, select the 
entire mesh, and go to Mesh → Snap → Cursor to Selected; then switch back to 
Object Mode and go to Top View (View → Top). Now add a plane (Add → Mesh → 
Plane), set its name to hood (from Item panel, Properties sidebar), and switch to 
Edit Mode.

17.	 Start by selecting the entire plane and scaling it down by a factor of 0.29 (press the S 
key, then type 0.29). Next, move the plane -3 cm along the Y axis (press the G key, Y 
key, then type -0.03). Then switch to Edge Select Mode, select only the lower edge 
that runs horizontally and move it 12 cm (0.12 units) along the Y axis (press the G 
key, Y key, then type 0.12).

18.	 Now switch to Front View (View → Front), select the entire plane and move it 70 
cm (0.7 units) along the Z axis (press the G key, Z key, then type 0.7). Now switch to 
Face Select Mode, extrude the face, press Escape, and then move the extrusion 2.5 
cm along the Z axis (press the G key, Z key, then type 0.025). Then perform a second 
extrusion, press Escape, then move the extrusion 30 cm along the Z axis (press the G 
key, Z key, then type 0.3). After moving the second extrusion, scale it down by a factor 
of 0.4 (press the S key, then type 0.4). Finally, let's perform a third extrusion, press 
Escape, and then move it up 75 cm (press the G key, Z key, then type 0.75).

19.	 Before assigning the material to the hood, let's select the entire mesh and go to 
Mesh → Normals → Recalculate Outside to make sure the normals are oriented 
correctly.

20.	 Then switch to Object Mode. Let's take a look at a screenshot showing the finished 
hood, between the cabinets on the wall:
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21.	 Since we are going to use the same material for the hood and the sink, we just need 
to go to the Material tab of the Properties Editor, click on the button with the red 
sphere icon, and select the brushedMetal material from the list.

That's it, we are done with the modeling and shading of our scene. Let's save the file 
before continuing.

Objective Complete - Mini Debriefing
For this part we used almost the same methodology as for creating the sink; we started by 
duplicating a part of a pre-existing mesh, separating it into a new object. Most of the time 
we were just extruding, scaling, and tweaking around.

Two useful tips we used are adding extra edge loops (close to other ones) to sharpen the 
shape of the mesh and using the Spin tool to create circular-extruded corners.

Classified Intel
Don't forget that the Spin tool uses the location of the 3D Cursor as the initial value for the 
Center parameter; thus it's highly recommended to move the 3D Cursor into a good place 
before applying the tool, by using the Cursor to Selected snap command.

Lighting and Background
This task will be very short; we just need to add a very basic lighting setup consisting of 
two lights and Ambient Occlusion. Then we will add a simple background for the window 
of our kitchen.

Engage Thrusters
1.	 We will start by setting up the camera for the scene. Let's go to Add → Camera, then 

go to the Object tab of the Properties sidebar, locate the Transform panel, and set 
the parameters as follows:

ff Location: 3.55 X, -3.586 Y, 1.852 Z

ff Rotation: 84.54º X, 0º Y, 37.6º Z

That's it for the camera, very easy.

A good way to set the camera is by switching to Camera View (View → Camera) 
and using Fly Navigation (View → Navigation → Fly Navigation) to move it 
around the scene as needed. Remember also that in Camera View it's possible to 
select the camera and use the Grab tool (G key) to pan the view.
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2.	 Next, let's add the first light of our lighting setup. Go to Add → Lamp → Sun, then 
go to the Object tab of the Properties Editor, locate the Transform panel, and set 
its parameters as follows:

ff Location: -2.12 X, -1.75 Y, 3.95 Z

ff Rotation: 45.92º X, -3.56º Y, -63.25º Z

3.	 Then let's go to the Object Data tab (sun icon) of the Properties Editor and set it as 
follows:

ff Lamp panel:

�� Color: 1.0 Red, 0.9 Green, 0.81 Blue

�� Energy: 1.0

ff Shadow panel:

�� Shadow Method: Ray Shadow

�� Samples: 8

�� Soft Size: 0.06

4.	 This light will provide a basic, uniform lighting entering through the window to our 
kitchen. This light will have a subtle yellow tint. Let's also set its name to sun (from 
the Item panel, Properties sidebar).

5.	 Now let's add a second light; go to Add → Lamp → Area and change its name to 
window-sky (from the Item panel, Properties sidebar). Then go to the Object tab of 
the Properties Editor, locate the Transform panel, and set its parameters as follows:

ff Location: -0.083 X, -0.85 Y, 1.75 Z

ff Rotation: 90º X, 0º Y, -90º Z

ff Scale: 1.0 X, 1.0 Y, 1.0 Z

The scale option is indicated because it must be left untouched from the original 
value, to avoid messing up the lighting setup (area lamps are very sensitive and 
scaling them affects their lighting quite a lot).

6.	 For the actual lamp parameters, let's go to the Object Data tab of the Properties 
Editor and set it as follows:

ff Lamp panel:

�� Color: 0.64 Red, 0.82 Green, 1.0 Blue

�� Energy: 1.0

�� Distance: 1.0

�� Gamma: 1.0
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ff Area Shape panel:

�� Shape: Rectangle

�� Size X: 1.4

�� Size Y: 1.15

ff Shadow panel:

�� Method: Ray Shadow

�� Samples X: 16

�� Samples Y: 16

This time we set a bluish light, using the Ray Shadow method to calculate shadows 
and with a high level of detail for them (16 for both X and Y). The rectangular shape 
is needed to accommodate the shape of the window properly.
Before setting the Ambient Occlusion parameters, let's take a look at a screenshot 
showing these two lamps in our scene:
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7.	 The third component for our lighting setup is enabling Ambient Occlusion. Let's go 
to the World tab of the Properties Editor and set it as follows:

ff Ambient Occlusion panel: Enabled

�� Factor: 0.3

�� Mode: Add

ff Gather panel:

�� Method: Raytrace

�� Distance: 0.5

�� Sampling Method: Adaptive QMC

�� Samples: 16

�� Threshold: 0.001

The Ambient Occlusion will add some very nice, subtle, soft shadowing to the scene, 
dramatically increasing the quality of the rendered image. We used a value of 0.3 
to have a subtle effect and raised the quality using the Raytrace method, along with 
high sampling values and very low threshold. The distance is set according to the 
scale of our scene, so that the "size" of the shadows plays nicely with the size of it.
At this point we could launch a render job and get a quite nice image; the only 
missing part is having a believable background in the window. Let's add it to finish 
the project.

8.	 Make sure that we are in Object Mode, then go to Add → Mesh → Plane and 
change the name of the new object to bg-sky (from the Item panel, Properties 
sidebar). Now let's go to the Object tab of the Properties Editor, locate the 
Transform panel, and set its parameters as follows:

ff Location: -2.851 X, 1.001 Y, 1.743 Z

ff Rotation: 90º X, 0º Y, -90º Z

ff Scale: 2.242 X, 1.058 Y, 1.058 Z

These will leave the background plane placed correctly for our camera to see it, but 
also avoid casting any shadow from the lights onto other objects.

9.	 Now let's go to the Material tab of the Properties Editor, add a new material, 
change its name to bg-sky, and set it as follows:

ff Diffuse Color: 0.0 Red, 0.0 Green, 0.0 Blue (Diffuse panel)

ff Shadeless: Enabled (Shading panel)

These very simple settings are necessary to have an empty (black) color to start from 
(we will add the texture over it) and enable the shadeless option to ensure that the 
texture will be rendered with the original colors (without shading calculations).
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10.	 To add the actual background image, let's go to the Texture tab of the Properties 
Editor, add a new texture, change its name to sky-pic, its type to Image or Movie, 
and set it as follows:

ff Image panel: Load the image Skies0239_L.jpg from the tex folder.

ff Influence panel:

�� Diffuse Color: Enabled, 1.0

�� Blend: Add

With this texture we just add the background image to the empty (black) canvas that we set 
in the global material settings.

And that's it, our scene is ready to be rendered.

Objective Complete - Mini Debriefing
This final part was just about adding a simple lighting setup, using two lights and Ambient 
Occlusion. We also added a background image to give some depth to the rendered image.

The lighting setup required just two lights: a sun light to create the strong highlight coming 
from above and entering to our scene through the window, and an area lamp, used to 
simulate the blue light coming from the atmosphere and entering our scene, also, through 
the window (hence the location of the area lamp). These two lights alone could not handle 
the entire lighting of the scene, so we added an extra element to the lighting setup: a basic 
Ambient Occlusion, with high quality to get very soft shadows.

The background plane was very easy to create and its material was created using the 
standard method of starting from an empty (black) material and then adding the image to 
it. For this background we also used the shadeless option, to get it rendered exactly as the 
image is, with no shading calculations at all.

Mission Accomplished
And that's it, a quite simple scene with a very nice final render result. We worked from 
scratch to create a simple room, including a moderately detailed window. We also created 
some nice cabinets with a very good fine-wood finish (by virtue of the texture we used), a 
sink with a nice (fake) brushed metal material, and a modern looking stove with a beautiful 
dark material.

For the lighting we learned to create a very basic setup that gives us extremely nice results: 
using just two lights and adding some Ambient Occlusion goodness, we were able to apply a 
clean, clear, and beautiful lighting to the scene.
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Let's take a look at the final result of all the hard work that we've done:

You Ready To Go Gung HO? 
A Hotshot Challenge

There are many ways to improve our kitchen; let's enumerate some of them:

ff Blurring the image used in the background plane could help to reinforce the sense 
of depth.

ff The perspective of the background image doesn't match the perspective of the 
scene very well. Searching for a background image with a different perspective 
would be helpful to solve that.

ff Adding detail and a complex material to the wall would improve the final render a 
lot.

ff Modeling more objects for the scene would be great; there are some obvious ones 
such as pots, plates, and so on.

ff We didn't apply any post-processing to our scene, but working the finished render 
through the compositor would allow us to add some finesse to our image.

ff Adding a fine bevel to the borders of the drawers, cab-cover, and cabinets would 
give a nice touch to the final image.

ff An easy way to improve the scene would be by replacing the current knobs with 
more complex ones.

ff Since the internal render engine could fall short in achieving the level of realism that 
we want, it would be great to work on exporting our scene to an external render 
engine and get our project to the next level. Luxrender and Yafaray are Open Source 
render engines, and there are commercial ones such as VRay and Maxwell Render.


